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Introduction
This section describes the features and functions of a Zebra printer that is running the 
Virtual Device-L application. 
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Overview

The Virtual Device-L application enables Zebra mobile and tabletop printers to work 
with many host systems that are using Labelpoint® printers. In most cases, no 
changes will be required to the host application. This feature can help customers to 
make a smooth transition to Zebra printers and save them the time and expense of 
having to rewrite their host software.

Virtual Device-L Features

The Virtual Device-L application:

• Uses existing features of Zebra printers, when available.

• Supports the Bluetooth®, Serial, Ethernet, WLAN, and USB interfaces.

• Offers many outline fonts, barcodes, and specific commands and features of 
target printer models (see Supported Fonts on page 43).

• Provides support of Labelpoint commands (see Commands on page 33).
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Supported Printers

This manual describes the Virtual Device-L language for Zebra mobile and tabletop 
printers and should be used by any person who needs to support that language on 
one of the following Zebra printers:

For complete printer operation, use this manual in combination with the User Guide 
for your printer.

Configuring Network Connectivity

Your printer may be equipped with one or more of the following interfaces:

• Bluetooth—For detailed information to connect a Bluetooth device, refer to the 
Bluetooth User Guide.

• Wired print server—For detailed information, refer to the ZebraNet Wired and 
Wireless Print Servers User Guide.

• Wireless print server (a/b/g/n)—For detailed information, refer to the ZebraNet 
Wired and Wireless Print Servers User Guide.

For other connectivity options, refer to the User Guide for your printer. Copies of these 
manuals are available at http://www.zebra.com/manuals.

Printer Firmware

iMZ Series V73.19.6Z and later

QLn Series V68.19.6Z and later

ZT200 Series V72.19.6Z and later

ZT400 Series V75.19.7Z and later

ZT510 V80.20.02Z and later

ZT600 Series V80.20.02Z and later

ZD400 Series V77.19.14Z or V84.20.05Z and later

ZD500 Series V74.19.6Z and later

ZD600 Series V84.20.05Z and later

ZQ300 Series V81.20.06Z and later

ZQ500 Series V76.19.10Z and later

Note • The Virtual Device-L language is supported only on 203 dpi printers.
08/06/2018 Virtual Device-L User Guide P1074583-004
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Notes
• Other command languages are disabled when running Virtual Device-L. However, 

Set/Get/Do (SGD) commands and file download all operate properly with 
Virtual Device-L enabled.

• Virtual Device-L fonts can only be used with Virtual Device-L commands. They 
cannot be used with other languages.

• The Virtual Device-L mode application will not respond to CPCL, ZPL, or EPL 
commands. Instead, commands will be processed by the Virtual Device-L 
application.
P1074583-004 Virtual Device-L User Guide 08/06/2018



Install, Register, and
Enable Virtual Device-L
This section provides you with instructions on how to install and enable the 
Virtual Device-L application on one or more Zebra printers. 
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Acquiring the Virtual Device Application

To get the Virtual Device app, perform the following from your computer:

1. Open a web browser and navigate to http://www.zebra.com/virtualdevices.

2. Locate your printer type in the list of printers, and then click Download Now.

3. Fill out the information on the Virtual Device Download Request form.

4. Click Submit.

5. Read the End User License Agreement.

6. Click Accept and Begin Download Now.

Your browser prompts you to open or save the archive containing the Virtual 
Device app.

7. Save and store the Virtual Device app archive file to your computer.

The archive file contains the following:

• The Virtual Device .NRD file to be downloaded to a Zebra printer.

• A .txt file that contains the SGD command for immediately activating the 
Virtual Device app.

8. Extract the files from the archive to your computer.
P1074583-004 Virtual Device-L User Guide 08/06/2018
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Downloading the Virtual Device-L Application

Zebra provides two options to download the Virtual Device-L app to the printer.

• On a computer with the ZDownloader Utility

The ZDownloader Utility is the only method shown in this manual. For instructions 
on how to download and install the ZDownloader Utility, see ZDownloader Utility 
on page 55.

• On an Android device with the Zebra Printer Setup Utility for Android Devices 
(available for free on Google Play™)

For information on using the Zebra Printer Setup Utility for Android Devices and to 
download the user guide, navigate to www.zebra.com/setup.

Using ZDownloader

The ZDownloader application can update Virtual Device-L files in Zebra printers 
connected by Serial, Parallel, USB, and IP Ethernet networks.

Figure 1 • Initial ZDownloader Screen

Adding Printers to the ZDownloader List

There are two ways to add printers to the list: 

• Auto-Detect (use for USB or IP Ethernet interfaces)

• Manual add (use for Serial, Parallel, or IP Ethernet interfaces)

If your printer is connecting via the serial or parallel interfaces, or is not detected by 
using the Auto-Detect method, use the Manual Add method.
08/06/2018 Virtual Device-L User Guide P1074583-004
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Auto-Detect Printers

Use Auto-Detect for USB or IP Ethernet interfaces. 

USB printers can only be added by using Auto-Detect. The ZDownloader utility can 
support as many USB printers as your computer can support (most computers 
typically can support up to 255).

Note • Ethernet connected printers are detected by the application broadcasting a 
UDP packet out onto the network. UDP port number 4201 is used for the 
discovery process. Some networks filter out UDP packets. This means that the 
ZDownloader utility may not be able to detect all of the printers on your network. 
See your network administrator for more information. If you are not able to Auto-
Detect your network printers, follow instructions for manually adding a printer.
P1074583-004 Virtual Device-L User Guide 08/06/2018
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To Auto-Detect printers connected via the USB or IP Ethernet interfaces, 
perform the following steps:

1. In the ZDownloader toolbar, select Printer > Auto-Detect.

OR

Right-click in the ZDownloader window and select Auto-Detect Printers.

The printers detected are added to the printer list.

Manually Add Printers

To manually add printers connected via the Serial, Parallel, or Network 
interfaces, perform the following steps:

1. In the ZDownloader toolbar, select Printer > Add….

OR

Right-click in the ZDownloader window and select Add Printer…. 

The following window appears.
08/06/2018 Virtual Device-L User Guide P1074583-004
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2. Add a printer name and your printer model in the appropriate fields.

3. What type of printer are you adding?

Adding a Serial Printer

4. Select the serial port to which the printer is connected.

If you are adding a… Then…

Serial Printer Go to Adding a Serial Printer.

Parallel Printer Go to Adding a Parallel Printer on page 16.

Network Printer Go to Adding a Network Printer on page 17.
P1074583-004 Virtual Device-L User Guide 08/06/2018
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5. Click Port Settings.

The following window appears.

6. Adjust the settings as necessary. The printer’s serial port settings must match the 
computer’s serial port settings. For more information about the settings, refer to 
the User Guide for your printer.

7. Click OK to save the port settings.

8. Click OK to add the printer.
08/06/2018 Virtual Device-L User Guide P1074583-004
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Adding a Parallel Printer

9. Set Communication Type to Parallel.

The available parallel ports will be shown in the Port drop-down box.

10. Select the port to which the printer is connected. No additional configuration is 
necessary.

11. Click OK to add the printer.
P1074583-004 Virtual Device-L User Guide 08/06/2018
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Adding a Network Printer

12. Set Communication Type to Network. 

The following window appears.

13. Enter the printer’s IP address.

14. Click OK to save the network settings.

15. Click OK to add the printer.

Modifying Printers in the List

To change printer settings for a printer in the list, perform the following steps:

1. Select the printer to modify. 
08/06/2018 Virtual Device-L User Guide P1074583-004
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2. In the toolbar, select Printer > Modify Printer….

OR

Right-click on the printer and select Modify Printer….

The printer settings for the selected printer are displayed.

3. Modify the settings as desired.

4. Click OK to save the settings.

Deleting Printers from the List

To delete printers from the list, perform the following steps:

1. Select one or more printers to delete. 
P1074583-004 Virtual Device-L User Guide 08/06/2018
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2. In the toolbar, select Printer > Delete.

OR

Right-click on one of the selected printers and select Delete Printer(s). 

The printer is removed from the list.

Downloading the Virtual Device App to Selected Printers

To download the Virtual Device-L app to your printer(s), you must select the file to 
send to each printer. ZDownloader, by default, downloads files to one printer at a time. 
If you have multiple printers to update and want to speed up the process, you can 
increase the number of simultaneous downloads. 

To allow simultaneous downloads, perform the following step:

1. Click Tools > Options….

The following prompt appears.

2. Raise the number shown to allow multiple simultaneous downloads.

3. Click OK.

Note • More simultaneous downloads require more of your computer resources. 
Some computers may slow down with simultaneous downloads or as more printers 
are added for simultaneous downloading.
08/06/2018 Virtual Device-L User Guide P1074583-004
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To download the Virtual Device app file to one or more printers, perform the 
following steps:

1. Select the printers to which you want to download the Virtual Device-L app file. To 
select multiple printers, hold down the Ctrl or Shift key, and then click on the 
desired printers.

2. In the toolbar, select File > Select Firmware File….

OR

Right-click on one of the selected printers and select Select Firmware File….

3. Navigate to the Virtual Device app file that you acquired previously.

4. Click Open.

The file that you selected appears under Download File for the selected printers.

Printers that are present in the list but that do not have a file selected will be 
ignored when Downloading starts.
P1074583-004 Virtual Device-L User Guide 08/06/2018
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5. Start the download process by doing one of the following:

• Select Printer > Download to Selected. 

• Select the printer(s) of interest and select the Printer and then select 
Download To Selected.

6. In the toolbar, select Printer > Download All.

OR

Right-click in the ZDownloader window and select Download All.

After downloading has begun, the progress of each printer will be shown in the 
Download Status column.

Canceling a Download in Progress

The Cancel Download toolbar button and the Printer > Cancel Download menu 
options become active when the files are downloading.

To cancel downloading to ALL printers in the list, perform the following step:

1. Click Printer > Cancel Download.

OR

Right-click in the ZDownloader window and select Cancel Download.

To cancel downloading to SPECIFIC printers in the list, perform the following step:

1. Select one or more printers with a download in progress.

2. Click Printer > Cancel Download.

OR

Right-click on a selected printer and select Cancel Download.
08/06/2018 Virtual Device-L User Guide P1074583-004



Getting Started
Registering the Virtual Device

22
Registering the Virtual Device

ZDownloader maintains a log file of all items downloaded to a Zebra printer along with 
the printer serial number. You can register your Virtual Device installation with Zebra 
Repair and Tech Support to ensure that a printer sent in for repair is returned with the 
Virtual Device installed, and when engaging Zebra Tech Support, they will have 
records of the item being loaded. To register your Virtual Device installation, you must 
send the log file created by ZDownloader to the Zebra log file management group.

ZDownloader Log File

To send the log file, complete these steps:

1. Based on your operating system, navigate to the appropriate folder:

• Microsoft® Windows® XP
C:\Program Files\Common Files\FirmwareDownloader

• Microsoft Windows 7, Windows 8, and Windows 10
C:\ProgramData\Zebra Technologies\Firmware Downloader and 
ZBI Key Manager

2. Copy the log file (DownloadLog.txt), and email to Zdownloader@zebra.com.

If you are downloading from several computers, you need to send the log file from 
each computer. If you download files to printers on one day and do not send the 
file the same day, please note this in your email so that the log file management 
group picks up the previous load detail. Otherwise, they only pick up the load data 
for the day that the log file is sent. 
P1074583-004 Virtual Device-L User Guide 08/06/2018
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Enabling the Virtual Device

You can enable Virtual Device-L by sending a Set/Get/Do (SGD) command to the 
printer or by selecting the option through the printer’s menus.

Using an SGD Command

To enable Virtual Device-L on your printer, send the following command:

! U1 setvar "apl.enable" "apl-l" 

To disable Virtual Devices on your printer and return to normal function, send the 
following command:

! U1 setvar "apl.enable" "none"

You must restart the printer after changing the value of apl.enable. For more 
information about this SGD command, see apl.enable on page 41.

Using the User Menus

This section includes instructions for the following printers:

• QLn420 Printers on page 24

• QLn320 and QLn220 Printers on page 27

• ZT230, ZT400 Series, ZT510, ZT600 Series, ZD500 Series, and ZD600 Series 
Printers on page 30

If necessary, refer to the User Guide for your printer for additional information about 
your printer’s control panel. 
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QLn420 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the 
Home icon.

The printer displays the Home Menu.

2. Use the ARROWS to navigate to the LANGUAGE menu.

PRINTER READY

VXXXXXXX

 SETTINGS 

 LANGUAGE 
P1074583-004 Virtual Device-L User Guide 08/06/2018
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3. Press the OK button.

The printer displays the LANGUAGE selection screen.

4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection 
screen.

LANGUAGE

▼ ENGLISH ▲

VIRTUAL DEVICE

▼ NONE ▲
08/06/2018 Virtual Device-L User Guide P1074583-004
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5. Use the UP or DOWN ARROW to scroll to the APL-L option.

6. Press the RIGHT SOFT KEY to select USE.

The printer restarts and uses the Virtual Device that you selected.

VIRTUAL DEVICE

▼ APL-L ▲

USE
P1074583-004 Virtual Device-L User Guide 08/06/2018
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QLn320 and QLn220 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the 
Home icon.

The printer displays the Home Menu.

2. Use the ARROWS to navigate to the SETTINGS menu.

Zebra QLn320
FW ver: XXXXXXXXXX
Baud Rate: 115200
Battery ok
IP Addr: 10.14.205.138

Menu

Communication Back

Settings Back
08/06/2018 Virtual Device-L User Guide P1074583-004
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3. Press the OK button.

The printer displays the VIRTUAL DEVICE selection screen.

4. Press the RIGHT ARROW to highlight the up arrow on the display.

5. With the up arrow highlighted, press the OK button until you scroll to the APL-L 
option.

Virtual Dev: none ▲ ▼

Menu Use Back

Virtual Dev: apl‐l ▲? ▼

Menu Use Back
P1074583-004 Virtual Device-L User Guide 08/06/2018
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6. Press the LEFT ARROW to highlight APL-L

7. Press OK to select USE.

The printer restarts and uses the Virtual Device that you selected.
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ZT230, ZT400 Series, ZT510, ZT600 Series, ZD500 Series, and ZD600 Series 
Printers

1. From the printer’s idle display screen, press the LEFT SELECT KEY to select the 
Home icon.

The printer displays the Home Menu.

Note • The ZT230 control panel is shown in this procedure. The control panel for the 
other printers is similar.

PRINTER READY

VXXXXXXX

HOME MENU

SETTINGS
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2. Use the ARROWS to navigate to the LANGUAGE menu.

3. Press the OK button.

The printer displays the LANGUAGE selection screen.

HOME MENU

SETTINGS

▼
LANGUAGE

ENGLISH ▲
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4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection 
screen.

5. Use the UP or DOWN ARROW to scroll to the APL-L option.

▼
VIRTUAL DEVICE

NONE ▲

▼
VIRTUAL DEVICE

APL-L ▲

USE
P1074583-004 Virtual Device-L User Guide 08/06/2018



33Getting Started
Enabling the Virtual Device
6. Press the RIGHT SOFT KEY or OK to select USE.

The printer restarts and uses the Virtual Device that you selected.

▼
VIRTUAL DEVICE

APL-L ▲

USE
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Commands
This section provides a listing of commands for use on your Zebra printer with the 
Virtual Device-L app.
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Table of Supported Commands

In the following commands, the parameters shown in carets < > are required while 
those shown in brackets [ ] are optional.

 

Syntax Command Function
Supported

(X)

Command Summary

!C Clear the label layout X

!D D S Document start —

!D D E Document end —

!D T M Turn off automatic cutter 
mode

—

!D T A Turn on automatic cutter 
mode

—

!D T T Execute a cut when in 
manual cutting mode

—

!D L 0 Turn off the take-label 
sensor

—

!D L 1 Turn on the take-label 
sensor

—

!K <n> Feed out n/10 mm of 
paper

—

!L G "<name>" Load the specified 
graphics file

X

!L M "<name>" Load the specified macro X

!L Terminate loading X

!M "<name>" Execute the specified 
macro

X

!N<n> <v> <i> <w> <u> Initialize the counters X

!P <n> Print X

!p <n> Dormant print (printkey 
mode)

—

!R Clearing variable 
information

X

!S <n> Status request X

!W <n> "<data>" Changing a single variable X
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Label Layout Definition Commands

Format 1

!F S <u> <b> <p> <a> <h> <s> <f> [wa] <"text">

Format 2

!F S <u> <b> <p> <a> <h> <w> <f> [s] <"text">

Scalable text field X

!F T <u> <b> <p> <a> <h> <w> <f> <”text”> Bitmap text field 
(deprecated)

X

!F C <u> <b> <p> <a> <h> <w> <s> [d] <”text”> Defining a barcode field X

!F C <u> <b> <p> <a> <h> <w> <o> [d] <”text”> Defining a 2D barcode 
field

X

Format 1

!F B <u> <b> <p> <a> <h> <w> <b> 

Format 2

!F B D <y0> <x0> <lw> <y1> <x1> 

Defining a line/box field X

!F G <u> <b> <p> <a> <h> <w> <"name"> Defining a graphics field X

Service Commands

!V 9 [m] Return software revision 
level

X

!V11 Return software date X

!V12 Return label count X

!V13 Return available dynamic 
RAM (in bytes)

X

!V16 Return PROM number X

!V17 Return total paper 
movement (in meters)

X

!V19 Return available file 
system memory (in bytes)

X

!V20 <hh:mm:ss> Set the time on the 
printer’s clock

X

!V21 <yy‐mm‐dd>
or

!V21 <yyyy‐mm‐dd>

Set the date on the 
printer’s clock

X

!V22 [m] Return printer date and 
time

X

!V23 <m> Return the font number X

!V24 <"name"> Return logo information X

!V25 <m> Return information about 
the logo specified

X

Syntax Command Function
Supported

(X)
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!V26 <"name"> Display the content of a 
macro

X

!V31 Return the length of the 
last paper movement (in 
1/10 mm)

X

!V32 <m> Return the current state of 
the specified counter

X

!V33 Return the number of 
failing dots on the 
printhead

X

!V34 <m> Return the position of 
failing dots identified by 
service command 33

X

!V39 Return the number of 
dormant printouts since 
the last !p<n> command

X

!V40 <m> Return the bitmap font 
number, where <m> is the 
physical number of the 
font, not the mapped 
number

X

!V44 Automatically set the 
sensitivity of the paper 
sensor

X

!V45 Set the default character 
spacing for all bitmap fonts

—

!V48 <m> Return information on the 
specified printer file 
system

—

!V61 <s> [r] [c] Set security level for 
PDF417

X

!V63 Return the printer serial 
number

X

!V80 <m> Show typeface by index 
<m>

X

!V81 <m> Show typeface by index 
<m>

—

!V93 [m] Return number of dormant 
printouts

—

!V100 Set the network IP 
address

X

!V101 Return the network IP 
address

X

Syntax Command Function
Supported

(X)
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!V102 <a>.<b>.<c>.<d> Set the network IP mask X

!V103 Return the network IP 
mask

X

!V104 <"host"> Set the network host name X

!V105 Return the network host 
name

X

!V106 <"m"> Set the domain name —

!V107 Return the domain name —

!V108 [m] Return any DHCP 
information received from 
the DHCP server

X

!V109 Get MAC address X

!V110 <a>.<b>.<c>.<d> Set the network default 
gateway

X

!V111 Return the network default 
gateway

X

!V114 Return the serial number 
of an RFID tag

—

!V115 Set a login script —

!V116 Return a login script —

!V117 Return the active port X

!V120 Return the printer model X

!V3194 [m] Delete specified macro, 
graphic, or font from the 
printer. If not specified, all 
files are deleted.

X

!V3196 Restart the printer X

!V3200 Reset all printer 
parameters to their 
defaults

X

!V3201 Disconnect port —

!V3209 <m> In Setup mode, set 
password for web server

—

!V35183 Enter User mode —

!V38153 Enter Setup mode —

Printer Configuration Commands

!Y2 <n> Print speed X

!Y3 <n> Barcode speed —

!Y4 <n> Blank feed speed —

Syntax Command Function
Supported

(X)
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!Y5 <n> Printhead type —

!Y6 Number of dots per mm of 
printhead

—

!Y7 <n> Motor steps per mm —

!Y8 <n> Printhead width in dots X

!Y9 <n> Dot mode —

!Y10 Manufacturing date —

!Y16 <n> Force DT X

!Y20 <n> Photosensor threshold 
level

—

!Y21 <n> Photosensor current level —

!Y23 <n> Maximum paper feed 
length (in 1/10 mm)

X

!Y24 <n> Dispensing feed (in 
1/10 mm)

X

!Y25 <n> COM2 baud rate —

!Y26 <n> COM2 parity —

!Y27 <n> COM2 word length —

!Y28 <n> COM2 stop bits —

!Y29 <n> COM2 input buffer size X

!Y30 <n> COM1 baud rate X

!Y31 <n> COM1 parity X

!Y32 <n> COM1 word length X

!Y33 <n> COM1 stop bits X

!Y34 <n> COM1 input buffer size —

!Y35 <n> Character set, supported 
code pages

X

!Y36 <n> ASCII code of the 
command character

X

!Y39 <n> LTS enable X

!Y40 <n> Minimum paper length to 
feed during a print cycle

X

!Y42 <n> Printing of bar code 
interpretation

X

!Y44 <n> Alternate end-of-line 
(EOL) character

X

!Y45 <n> Disable CR as end-of-line X

!Y46 <n> Strobe time —

Syntax Command Function
Supported

(X)
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!Y50 <n> Silent mode —

!Y62 Printer production year —

!Y63 Printer serial number —

!Y66 <n> Enable application —

!Y67 <n> Printkey mode —

!Y68 <n> Horizontal print position 
adjustment (in 1/10 mm 
increments)

X

!Y69 <n> Vertical print position 
adjustment (in 1/10 mm 
increments)

X

!Y72 <n> to !Y79 <n> Map physical font to 
logical number

—

!Y89 <n> Allow command character 
anywhere on the line

X

!Y92 <n> Stacked printers mode 
(daisy chaining)

—

!Y93 <n> LTS auto repeat —

!Y100 <n> Automatically reverse 
paper feed before printing

—

!Y101 <n> to !Y106 <n> Set the intercharacter 
spacing for the specified 
bitmap font

X

!Y132 <n> Enable mapping of 
barcode information

—

!Y134 <n> Enable a recover page —

!Y136 <n> Set PDF417 code security 
level

X

!Y137 <n> Set maximum number of 
columns for PDF417 

X

!Y138 <n> Set maximum number of 
rows for PDF417

X

!Y145 <n> Set timeout value X

!Y146 <n> Set line spacing, based on 
a percentage of the font 
height

X

!Y150 <n> COM1 communication 
mode

—

!Y151 <n> COM1 TCP port —

Syntax Command Function
Supported

(X)
08/06/2018 Virtual Device-L User Guide P1074583-004



Commands
Table of Supported Commands

40
!Y152 <n> COM2 communication 
mode

—

!Y153 <n> COM1 TCP port —

!Y156 <n> COM1 flow control X

!Y157 <n> COM2 flow control —

!Y162 <n> Enable reverse video 
mode for text fields

X

!Y167 <n> Set sensor type X

!Y168 <n> Set historic control —

!Y170 <n> Sensor detect —

!Y178 <n> Set maximum label width 
(in 1/10 mm increments)

X

!Y179 <n> Set maximum label height 
(in 1/10 mm increments)

X

!Y180 <n> Specify raw data port 
number

X

!Y185 <n> Update best-before date 
update day

X

!Y186 <n> Update best-before date 
truncation day

X

Syntax Command Function
Supported

(X)
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Set/Get/Do (SGD) Commands

The following SGD commands were added for use with your Virtual Device app. For 
more detailed information on SGD commands, see the Programming Guide for 
ZPL II®, ZBI 2, Set/Get/Do, Mirror, and WML (formerly the ZPL II Programming 
Guide).

apl.enable

Description  This command enables or disables a Virtual Device app.

Type  setvar

apl.version

Description  This command returns the version of the currently running Virtual 
Device app.

Type  getvar

Note • 

• ZPL and CPCL may not function normally when a Virtual Device app is enabled. 
• You must restart the printer after changing the value of apl.enable.

Commands Details

setvar This command instructs the printer to enable a virtual device. 

Format: ! U1 setvar "apl.enable" "value" 
Values: 

"apl-l" = enable Virtual Device-L
"none" = disable any Virtual Device app (ZPL and CPCL function normally)

Example 1 • This example shows how to enable the Virtual Device-L app:

! U1 setvar "apl.enable" "apl-l"

Example 2 • This example shows how to disable the Virtual Device-L app:

! U1 setvar "apl.enable" "none"

Commands Details

getvar Format: ! U1 getvar "apl.version" 
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apl.framework_version

Description  This command returns the level of support for Virtual Devices in the 
printer operating system.

Type  getvar

Commands Details

getvar Format: ! U1 getvar "apl.framework_version" 
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Supported Fonts
This section provides you with examples of the fonts available on the Zebra printers 
with Virtual Device-L.
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Table 1 • Supported Fonts

Font Examples

1 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Code Page 1252
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2 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
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2 Code Page 1252

Table 1 • Supported Fonts (Continued)

Font Examples
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3 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
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5 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
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6 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
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24455 Standard Code Page 850

Code Page 852 Code Page 1143 Standard

Code Page 1143 Special Code Page 1152

Table 1 • Supported Fonts (Continued)

Font Examples
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94021 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
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94023 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
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94029 Standard

Code Page 850 Code Page 852

Code Page 1143 Standard
[

Code Page 1143 Special

Table 1 • Supported Fonts (Continued)

Font Examples
08/06/2018 Virtual Device-L User Guide P1074583-004



Supported Fonts54
94030 Standard Code Page 850

Code Page 852 Code Page 1143

Code Page 1252 Standard Code Page 8859

Table 1 • Supported Fonts (Continued)

Font Examples
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ZDownloader Utility
This section provides you with the instructions for downloading and installing the 
ZDownloader Utility.
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Downloading the ZDownloader Utility

To download the ZDownloader Utility, perform the following from your computer:

1. Open a web browser and navigate to www.zebra.com.

2. Click on the Support & Downloads header on the webpage.

3. Select a printer.

4. When the printer page opens, locate and select the Software Utilities tab.

5. Scroll down to the ZDownloader Utility and select the Download link. 

6. Click on the Accept and Begin Download Now button. 

The installation file download will begin.

Note • You will be prompted to create a user profile or login to www.zebra.com 
with an existing profile to download the ZDownloader Utility.
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Installing the ZDownloader Utility
To install the ZDownloader Utility, perform the following from your computer:

1. Run the installation file after the download is complete.

2. If you are prompted to allow the application to make changes to your computer, 
click Yes.

The utility installs on your computer. When installation is complete, the Firmware 
Downloader and ZBI Key Manager installation wizard appears.

3. Click Next.

The End User License Agreement appears.
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4. Read the terms of the agreement.

5. Click the checkbox to accept the terms.

6. Click Next.

7. Click Next.

The installation wizard displays information about the installation.
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8. Click Next.

The installation wizard installs the application.

9. Click Finish to close the wizard.
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acquiring the app, 10
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auto-detect printers, 12

C
commands and command parameters, 34
connectivity options, 7

D
disabling the Virtual Device
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QLn320 and QLn220 printers, 26
QLn420 printers, 23
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E
enabling the Virtual Device

by apl.enable SGD command, 41
through the control panel
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QLn420 printers, 23
ZT230, ZT400 series, ZT510, ZT600 se-

ries, ZD500 series, and ZD600
series printers, 29
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F
features, 6
fonts, 43

I
IP Ethernet printers

auto-detect, 12
manually add, 13

L
liability, 2

M
manually add printers, 13
modifying printer communication settings 

through ZDownloader, 16

P
parallel printers, 13
print servers, 7

S
serial interface

add printers, 13
Set/Get/Do (SGD) commands, 41
supported fonts, 43
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U
USB printers, 12

V
version

level of support for Virtual Devices, 42
of Virtual Device, 41

Virtual Device version, 41

W
wired print server

auto detect, 12
for more information, 7
manually add, 13

wireless print server
auto detect, 12
for more information, 7
manually add, 13

Z
ZDownloader

adding printers, 11
canceling a download in progress, 20
deleting printers, 17
downloading the Virtual Device app to printers, 

18
downloading ZDownloader, 56
installing ZDownloader, 57
modifying printer settings, 16

zebra printer setup utility for android devices, 11
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