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Introduction

This section describes the features and functions of a Zebra printer that is running the
Virtual Device-Ax application.
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Overview

Overview

The Virtual Device-Ax application enables Zebra Link-OS printers to work with many
host systems that are using Datamax-O’Neil Apex 3 or Apex 4 printers. In most cases,
no changes will be required to the host application. This feature can help customers to
make a smooth transition to Zebra printers and save them the time and expense of
having to rewrite their host software.

Virtual Device-Ax Features

The Virtual Device-Ax application:
» Uses existing features of Zebra printers, when available.

« Offers fonts similar to the original device. These fonts will use 120 KB or more of
memory space.

» Supports the Bluetooth®, Serial, Ethernet, WLAN, and USB interfaces.

« Offers many outline fonts and specific commands and features of target printer
models (see Supported Fonts on page 42).

* Provides support of Datamax-O’Neil commands (see Commands on page 34).
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Supported Printers

Supported Printers

This manual describes the Virtual Device-Ax language for Zebra Link-OS printers and
should be used by any person who needs to support that language on one of the
following Zebra printers:

Printer Firmware

iMZ Series V73.19.6Z and later
QLn Series V68.19.6Z and later
ZT200 Series V72.19.6Z and later
ZT400 Series V75.19.7Z and later
ZT510 V80.20.02Z and later
ZT600 Series V80.20.02Z and later
ZD400 Series V77.19.14Z or V84.20.05Z and later
ZD500 Series V74.19.6Z and later
ZD600 Series V84.20.05Z and later
ZQ300 Series V81.20.06Z and later
ZQ500 Series V76.19.10Z and later

Note ¢ The Virtual Device-Ax language is supported only on 203 dpi printers.

For complete printer operation, use this manual in combination with the User Guide
for your printer.

Configuring Network Connectivity

Your printer may be equipped with one or more of the following interfaces:

* Bluetooth—For detailed information to connect a Bluetooth device, refer to the
Bluetooth User Guide.

+ Wired print server—For detailed information, refer to the ZebraNet Wired and
Wireless Print Servers User Guide.

» Wireless print server—For detailed information, refer to the ZebraNet Wired and
Wireless Print Servers User Guide.

For other connectivity options, refer to the User Guide for your printer. Copies of these
manuals are available at http://www.zebra.com/manuals.
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Notes

Notes

« Other command languages are disabled when running Virtual Device-Ax.
However, Set/Get/Do (SGD) commands and file download all operate properly
with Virtual Device-Ax enabled.

+ Virtual Device-Ax fonts can only be used with Virtual Device-Ax commands. They
cannot be used with other languages.

* The Virtual Device-Ax mode application will not respond to CPCL, ZPL, or EPL
commands. Instead, commands will be processed by the Virtual Device-Ax
application.
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Install, Register, and
Enable Virtual Device-AXx

This section provides you with instructions on how to install and enable the
Virtual Device-Ax application on one or more Zebra printers.
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Acquiring the Virtual Device Application

Acquiring the Virtual Device Application

To get the Virtual Device app, perform the following from your computer:

1. Open a web browser and navigate to http://www.zebra.com/virtualdevices.
2. Locate your printer type in the list of printers, and then click Download Now.
3. Fill out the information on the Virtual Device Download Request form.

4. Click Submit.

5. Read the End User License Agreement.

6. Click Accept and Begin Download Now.

Your browser prompts you to open or save the archive containing the Virtual
Device app.

7. Save and store the Virtual Device app archive file to your computer.
The archive file contains the following:

+ The Virtual Device .NRD file to be downloaded to a Zebra printer.

+ A .txt file that contains the SGD command for immediately activating the
Virtual Device app.

8. Extract the files from the archive to your computer.
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Downloading the Virtual Device-Ax Application

Downloading the Virtual Device-Ax Application

Zebra provides two options to download the Virtual Device-Ax app to the printer.

* On a computer with the ZDownloader Utility

The ZDownloader Ultility is the only method shown in this manual. For instructions
on how to download and install the ZDownloader Utility, see ZDownloader Utility
on page 45.

* On an Android device with the Zebra Printer Setup Utility for Android Devices
(available for free on Google Play™)

For information on using the Zebra Printer Setup Utility for Android Devices and to
download the user guide, navigate to http://www.zebra.com/setup.
Using ZDownloader
The ZDownloader application can update Virtual Device-Ax files in Zebra printers

connected by Serial, Parallel, USB, and IP Ethernet networks.

Figure 1 ¢ Initial ZDownloader Screen

File Edit View Printer Tools ZBI ZPoints Help
& % ?

Printer Mame | Model | Port | Download File | Download Status

Adding Printers to the ZDownloader List

There are two ways to add printers to the list:
+ Auto-Detect (use for USB or IP Ethernet interfaces)

* Manual add (use for Serial, Parallel, or IP Ethernet interfaces)

If your printer is connecting via the serial or parallel interfaces, or is not detected by
using the Auto-Detect method, use the Manual Add method.
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Downloading the Virtual Device-Ax Application

Auto-Detect Printers

Use Auto-Detect for USB or IP Ethernet interfaces.

Note * Ethernet connected printers are detected by the application broadcasting a
UDP packet out onto the network. UDP port number 4201 is used for the
discovery process. Some networks filter out UDP packets. This means that the
ZDownloader utility may not be able to detect all of the printers on your network.
See your network administrator for more information. If you are not able to Auto-
Detect your network printers, follow instructions for manually adding a printer.

USB printers can only be added by using Auto-Detect. The ZDownloader utility can
support as many USB printers as your computer can support (most computers
typically can support up to 255).

*, Untitled - ZDownloade o] o

| Eile Edit Wiew Printer Tools ZBI ZPoints Help

i s

L R %

Printer Mame | lﬁ%del | Port | Download File | Download Status

Auto-Detect connected printers
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Downloading the Virtual Device-Ax Application

To Auto-Detect printers connected via the USB or IP Ethernet interfaces,
perform the following steps:

1. In the ZDownloader toolbar, select Printer > Auto-Detect.
OR
Right-click in the ZDownloader window and select Auto-Detect Printers.
The printers detected are added to the printer list.

P Untitled - 7ZDounioats

Eile Edit View Printer Tools ZBI ZPoints Help

IR IEED IR TIE
Printer Name | Model | Port | Download File | Download Status

@Printerﬂl Zebra XX 19216802 Mone Selected
@Printer#l Zebra XX UsSB Mone Selected

Manually Add Printers

To manually add printers connected via the Serial, Parallel, or Network
interfaces, perform the following steps:

1. In the ZDownloader toolbar, select Printer > Add....
OR
Right-click in the ZDownloader window and select Add Printer....
The following window appears.

Printer Settings

Frinter Marme: IF'rintertH

Printer kModel: I

Comrmunication Type: I Serial LI

Fort: II:EIM1 vI F'u:urtSetlingsl

Frinter Calibration after r
download: [EPL Only)

(] I Cancel |
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Downloading the Virtual Device-Ax Application

2. Add a printer name and your printer model in the appropriate fields.

3. What type of printer are you adding?

If you are adding a... Then...

Serial Printer Go to Adding a Serial Printer.

Parallel Printer Go to Adding a Parallel Printer on page 16.
Network Printer Go to Adding a Network Printer on page 17.

Adding a Serial Printer

4. Select the serial port to which the printer is connected.

Frinker Mame: |F'rinter1¢1

Prirter M adel: |EE|:|ra 3o

Communication Type: | Sernal j

Part: |COM1 | Port Settings

Printer Calibration after =
download: [EPL Only]

C o]
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Downloading the Virtual Device-Ax Application

5. Click Port Settings.
The following window appears.

Fort Settings

Bitz per zecond: I 9600

Data bits: I a8

Farity: I Mane

Stop bits: I 1

Flows Cantrol I Hardware

Restore Defaults

6. Adjust the settings as necessary. The printer’s serial port settings must match the
computer’s serial port settings. For more information about the settings, refer to

the User Guide for your printer.
7. Click OK to save the port settings.

8. Click OK to add the printer.
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Adding a Parallel Printer

9. Set Communication Type to Parallel.

The available parallel ports will be shown in the Port drop-down box.

Printer Mame: IF'rintertM

Prirter M adel: I Zebira s

Communication T ype:; IF'araIIeI

Paort: ILF'T1 vI

Printer Calibration after r
download: [EPL Only]

] I Cancel |

10. Select the port to which the printer is connected. No additional configuration is

necessary.

11. Click OK to add the printer.
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Adding a Network Printer

12. Set Communication Type to Network.
The following window appears.

Printer Marme: IF'rinter#Eﬂ

Prirter M adel: IZEbra ol

Communication T ype:; I M etwork,

TEF'HIF';’-‘«ddress:I o .0

Part: IEI'I Qo

Printer Calibration after r
download: [EPL Only]

] I Cancel |

13. Enter the printer’'s IP address.
14. Click OK to save the network settings.

15. Click OK to add the printer.

Modifying Printers in the List

To change printer settings for a printer in the list, perform the following steps:

1. Select the printer to modify.

File Edit View Printer Tools ZBI ZPoints Help

SIS G EEE N | P
Printer Namel Model I Port I Download File I Download Status
ST Zebra XX 19216802 None Selected

Zebra XXX USB Mone Selected
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Downloading the Virtual Device-Ax Application

2. In the toolbar, select Printer > Modify Printer....
OR
Right-click on the printer and select Modify Printer....
The printer settings for the selected printer are displayed.

Printer Settings =

Frinter Marme: IF'rintertH

Printer bodel: IZel:ura o

Comrmunication Type: | M etk LI

TCPAP Address | 192 0168 . 0 . 2

Fort: IEI‘I Qo

Frinter Calibration after r
download: [EPL Only)

Cancel |

3. Modify the settings as desired.

4. Click OK to save the settings.

Deleting Printers from the List

To delete printers from the list, perform the following steps:

1. Select one or more printers to delete.

File Edit View Printer Tools ZBI ZPoints Help

SIS G EEE N | P

Printer Namel Model I Port I Download FilEI Download Status

SENEN  Zebra XXX 19216802 Mone Selected
Zebra XXX USE Mone Selected
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Downloading the Virtual Device-Ax Application

2. In the toolbar, select Printer > Delete.
OR
Right-click on one of the selected printers and select Delete Printer(s).
The printer is removed from the list.

. Untitled - ZDownloade pl=ly

l File Edit View Printer Tools ZBI ZPoints Help
AR ?
Printer Name| Model | Port | Download File | Download Status
@F‘rinter#_? Zebra XX USB Mone Selected

Downloading the Virtual Device App to Selected Printers

To download the Virtual Device-Ax app to your printer(s), you must select the file to
send to each printer. ZDownloader, by default, downloads files to one printer at a time.
If you have multiple printers to update and want to speed up the process, you can
increase the number of simultaneous downloads.

- Note * More simultaneous downloads require more of your computer resources.
5 Some computers may slow down with simultaneous downloads or as more printers
are added for simultaneous downloading.

To allow simultaneous downloads, perform the following step:

1. Click Tools > Options....
The following prompt appears.

x

Maximum Simultaneous Downloads (1-99): E

OK Cancel |

2. Raise the number shown to allow multiple simultaneous downloads.

3. Click OK.
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Downloading the Virtual Device-Ax Application

To download the Virtual Device app file to one or more printers, perform the
following steps:

1. Select the printers to which you want to download the Virtual Device-Ax app file.
To select multiple printers, hold down the Ctrl or Shift key, and then click on the
desired printers.

File Edit View Printer Tools ZBI ZPeoints Help

SOH GEEE K | P

Printer Namel Model I Port I Download FiIeI Download Status
Lebra 00X 1921680.2  Mone Selected

Zebra XK USB Mone Selected

Zebra XXX 192168013 MNone Selected
ﬁprinter#-d Zebra XX LPT1 Mone Selected

2. In the toolbar, select File > Select Firmware File....
OR
Right-click on one of the selected printers and select Select Firmware File....

3. Navigate to the Virtual Device app file that you acquired previously.

4. Click Open.
The file that you selected appears under Download File for the selected printers.

Printers that are present in the list but that do not have a file selected will be
ignored when Downloading starts.

File Edit Miew Printer Tools ZBI ZPoints Help

GG GEEE K ak| P
Printer Namel Model | Port | Download File | Download Status

@Printer#l Lebra X30{ 192168.0.2 CFILEMAME.nrd
@ Printer®2  Zebra XK USB Mone Selected

@ Printer#3  Zebra XXX 192.168.013 CFILEMAME.nrd
@ Printer®d  Zebra XXX LPT1 Mone Selected
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5. Start the download process by doing one of the following:
» Select Printer > Download to Selected.
» Select the printer(s) of interest and select the Printer and then select
Download To Selected.
6. In the toolbar, select Printer > Download All.
OR
Right-click in the ZDownloader window and select Download All.

After downloading has begun, the progress of each printer will be shown in the
Download Status column.

. Untitled - ZDownloader ~E-

|| Eile Edit View Printer Tools ZBI ZPoints Help

X % ® ?

Printer Name| Meodel | Port | Download File | Download Status
@Printer—ﬂl Zebra XX 19216802  CFILEMAME.nrd | Se——— e |
@ Printer#2  Zebra X30{ USB Mone Selected
@Printer—fﬂ Lebra XX 192168013 C:FILENAME.nrd
@ Printer#d  Zebra x2{ LPT1 Mone Selected

Canceling a Download in Progress

The Cancel Download toolbar button and the Printer > Cancel Download menu
options become active when the files are downloading.

To cancel downloading to ALL printers in the list, perform the following step:

1. Click Printer > Cancel Download.
OR
Right-click in the ZDownloader window and select Cancel Download.

To cancel downloading to SPECIFIC printers in the list, perform the following step:
1. Select one or more printers with a download in progress.

2. Click Printer > Cancel Download.
OR
Right-click on a selected printer and select Cancel Download.

08/28/2018 Virtual Device-Ax User Guide P1079049-003
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Registering the Virtual Device

Registering the Virtual Device

ZDownloader maintains a log file of all items downloaded to a Zebra printer along with
the printer serial number. You can register your Virtual Device installation with Zebra
Repair and Tech Support to ensure that a printer sent in for repair is returned with the
Virtual Device installed, and when engaging Zebra Tech Support, they will have
records of the item being loaded. To register your Virtual Device installation, you must
send the log file created by ZDownloader to the Zebra log file management group.

ZDownloader Log File

To send the log file, complete these steps:

1. Based on your operating system, navigate to the appropriate folder:

+  Microsoft® Windows® XP
C:\Program Files\Common Files\FirmwareDownloader

*  Microsoft Windows 7, Windows 8, and Windows 10
C:\ProgramData\Zebra Technologies\Firmware Downloader and
ZBI Key Manager

2. Copy the log file (DownloadLog.txt), and email to Zdownloader@zebra.com.

If you are downloading from several computers, you need to send the log file from
each computer. If you download files to printers on one day and do not send the
file the same day, please note this in your email so that the log file management
group picks up the previous load detail. Otherwise, they only pick up the load data
for the day that the log file is sent.
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Enabling the Virtual Device

You can enable Virtual Device-Ax by sending a Set/Get/Do (SGD) command to the
printer or by selecting the option through the printer's menus.

Using an SGD Command

To enable Virtual Device-Ax on your printer, send the following command:

! Ul setvar "apl.enable" "apl-ax"

To disable Virtual Devices on your printer and return to normal function, send the
following command:

! Ul setvar "apl.enable" "none"

You must restart the printer after changing the value of apl.enable. For more
information about this SGD command, see apl.enable on page 40.

Using the User Menus

This section includes instructions for the following printers:
* QLn420 Printers on page 24
* QLn320 and QLn220 Printers on page 27
» Supported ZTxxx and ZDxxx Printers with a Display on page 30

If necessary, refer to the User Guide for your printer for additional information about
your printer’s control panel.

08/28/2018
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Enabling the Virtual Device

QLNn420 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the

Home icon.

O ‘Tull 2 & n O NN
PRINTER READY

VXXXXXXX

L

O

The printer displays the Home Menu.

9‘”’.|I|E_li;@ﬁ®|m
Y1 & [
= B [F D

<

2. Use the ARROWS to navigate to the LANGUAGE menu.

O Tall 2 @ n O NN

EESS
el M
O | o
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3. Press OK.

The printer displays the LANGUAGE selection screen.

O ‘Tull 2 & n O NN
LANGUAGE

v ENGLISH A

=

Getting Started
Enabling the Virtual Device

4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection

screen.

O ‘Tull 2 & n O NN
VIRTUAL DEVICE

v NONE A

08/28/2018
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Enabling the Virtual Device

5. Use the UP or DOWN ARROW to scroll to the APL-Ax option.

O ‘Tull 2 & n O NN
VIRTUAL DEVICE

v APL-AX A

=) USE]

N
<>

6. Press the RIGHT SOFT KEY to select USE.

O

The printer restarts and uses the Virtual Device that you selected.
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QLNn320 and QLN220 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the
Home icon.

O ‘Tull 2 & n O NN

Zebra QLn320

FW ver: XXXXXXXXXX
Baud Rate: 115200
Battery ok

IP Addr: 10.14.205.138
Menu

O

The printer displays the Home Menu.
O Tall R @G d© NN
&

L]
A (1

Communication Back

2. Use the ARROWS to navigate to the SETTINGS menu.

O ‘Tull 2 & n O NN

N

(@)
@ @ [

Settings Back

SA2
>
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Enabling the Virtual Device

3. Press OK.

The printer displays the VIRTUAL DEVICE selection screen.

4. Press the RIGHT ARROW to highlight the up arrow on the display.

O ‘Tull 2 & n O NN

Virtual Dev: none A v

Menu Use Back

5. With the up arrow highlighted, press the OK button until you scroll to the APL-Ax

option.

O ‘Tull 2 & n O NN

Virtual Dev: apl-ax [ V

Menu Use Back

P1079049-003
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Enabling the Virtual Device

6. Press the LEFT ARROW to highlight APL-Ax

7. Press OK to select USE.

The printer restarts and uses the Virtual Device that you selected.
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Enabling the Virtual Device

Supported ZTxxx and ZDxxx Printers with a Display

Note * The ZT230 control panel is shown in this procedure. The control panel for the

other printers is similar.

1. From the printer’s idle display screen, press the LEFT SELECT KEY to select the

Home icon.

L.

>

PRINTER READY

VXXXXXXX

The printer displays the Home Menu.

HOME MENU
1 &
= [ @
e SETTINGS]
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2. Use the ARROWS to navigate to the LANGUAGE menu.

HOME MENU
e J|

7 &
B

=

] SETTING

ts

The printer displays the LANGUAGE selection screen.

3. Press OK.

LANGUAGE
v ENGLISH A

Getting Started
Enabling the Virtual Device
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Enabling the Virtual Device

4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection
screen.

VIRTUAL DEVICE
v NONE A

f

5. Use the UP or DOWN ARROW to scroll to the APL-Ax option.

VIRTUAL DEVICE
v APL-AX A

f USE|

L
(=)
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Enabling the Virtual Device

6. Press the RIGHT SOFT KEY or OK to select USE.

VIRTUAL DEVICE
v APL-AX

S

The printer restarts and uses the Virtual Device that you selected.
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Commands

This section provides a listing of commands for use on your Zebra printer with the
Virtual Device-Ax app.

Contents
Table of Supported Commands. . . ... . .. 35
Set/Get/Do (SGD) Commands. . ... ..ottt e 40
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Table of Supported Commands

Commands
Table of Supported Commands

For more information about the commands, refer to the documentation that came with
your printer.

Syntax Command Function Sup(a;‘)/o;ted Notes
Communications
EOT End of Transmission/Print Buffer v
Contents
XON Transmitter ON —
XOFF Transmitter OFF —
Character Sets
ESC F n Select Character Set v
ESC K n CR Select Character Pitch: Mode 1 v Fonts 2,4,5,7, 12,13,
and 15 are supported.
ESC kn Select Character Pitch: Mode 2 v Fonts 2, 4, and 5 are
supported.
So Double Wide ON —
SI Double Wide OFF —
FS Double High ON —
GS Double High OFF —
ESC a n Set Text Line Spacing v
Character Attributes
ESC U n
n=0or1 Emphasized Printing Mode (Bold) v
n=Uoru Underline Printing Mode v
n=Rorn Reverse Print —
ESC F n Right to Left and Left to Right —
Printing
Horizontal Position
CR Carriage Return —
BS Backspace —
HT Horizontal Tab —
ESC T Hn Set Horizontal Tab Width v
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Table of Supported Commands

Syntax Command Function Sup(u‘)/or)'ted Notes
Vertical Position
LF Line Feed —
ESC J n Variable Size Line Feed v
ESC Q J n Variable Size Reverse Line Feed v
vT Vertical Tab —
ESC T Vn Set Vertical Tab Height v
FF Form Feed —
ESC T F n1 n2 Set Form Feed Length in Dot v
Lines
Bar Codes
ESC z t n h data CR |Print Barcode v
LF
ESC Z t n h data CR |Print Barcode with Human v
LF Readable Text
ESC z h n Barcode Height Multiplier v
Graphics
ESC V n1 n2 data |8-Bit Graphics —
ESC v h w counter |8-Bit Compressed Graphics v
data
Printer Controls—Data Processing
ESC P $ Enable Buffer Mode v
ESC P # Disable Buffer Mode v
EOT Print Buffer Contents v
ESC P + Enable EOT Control Character —
Transmission
ESC P - Disable EOT Control Character —
Transmission
Printer Controls—Printed Output Adjust
ESC P n Print Contrast —
Printer Controls—Reset
CAN Cancel —
ESC @ Reset Printer and Load Default v Consumed but not
Setup processed
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Table of Supported Commands

Syntax Command Function Sup(a;‘)/o;ted Notes
Printer Controls—Power
ESC M nmeo CR |Auto Power Down Command v
ESC M HH MM SS © CR|Extended Auto Power Down v
Command
Printer Status
STX Query Print Buffer and Timer- v
MCR Status
SYN Query Print Buffer, Battery —
Voltage, Timer-MCR, and
Printhead Temperature
ESC P ~ Print Battery Voltage —
ESC P ( Query Printer Firmware Version —
ESC P ) Query Printer Model and —
Hardware Revision Level
Magnetic Card Reader
ESC M n1 n2 t (CR) |Read Magnetic Card Data v
ESC m n1 n2 t (CR)
ESC C Cancel Magnetic Card Data Read —
Command
Black Mark Sensing Control
ESC Q Q@ n CR Set Paper-Out Sensitivity v
ESC Q R CR Enable Black Mark Reporting v
ESC Q r CR Disable Black Mark Reporting v
Black Mark Sensing Command Mode
ESC Q F n CR Forward Seek Black Mark v
ESC Q B n CR Reverse Seek Black Mark v
ESC Q ? ? n1 n2 |Black Mark Found (response from v
printer)
ESC Q @ @ n1 n2 |Black Mark Not Found (response v
from printer)
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Table of Supported Commands

Syntax Command Function Sup(u‘)/or)'ted Notes
Black Mark Sensing Auto Mode
ESC Q f e CR Enable Front Black Mark Sensor v
ESC Q f d CR Disable Front Black Mark Sensor v
ESC Q b e CR Enable Back Black Mark Sensor v
ESC Q b d CR Disable Back Black Mark Sensor v
ESC Q f x CR Disable Both Front and Back v
ESC Q b x CR Black Mark Sensors
ESC QD + n Printed Receipt/Label Presenter v
ESC Q P n Positive Adjust
ESC QD - n Printed Receipt/Label Presenter v
Negative Adjust
ESC Q nin2 Advance n1n2 from Q mark N4
(Line Print mode emulation only)
Page Print Commands—Configuration
ESC P P Enter Page Printing Mode v
BeginPage(); Mark Beginning of a Page v
SetPageSize (w,h); |Define the Page Size v
SetMargin (Lm,tm) |Set Margins v
EndPage(); Mark Page End, Print, and Exit v
Page Print Commands—Draw Commands
DrawText (x,y, Draw Text v » Angle parameter is
color, angle, consumed but not
string"”); processed
« Setting Font with
<f=value> within
"string" is supported
DrawRectange Draw Rectangle v
(x1,y1,x2,y2,
color,width);
DrawBarcode Draw Barcode v
(x,y,angle,
annotate,
type, height,
l’data ");
Download—Printer Default Setup
ESCD S Select Setup Download Mode v
ESC S L Start Default Download Process —
ESC S T oxFF CR |Stop Download Process —
ESC S B CR Store In Flash Default Setup Data —
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Syntax Command Function Sup(u‘)/or)'ted Notes
Download—Self Test Message Hardware Information
ESCD S Select Setup Download Mode —
ESC S I Start Hardare Information Process —
Download
ESC S T oxFF CR |Stop Download Process —
ESC S B CR Store In Flash Default Setup Data —
ESC L g 8 Print Hardware Information —
Download—Logo
ESC D L CR LF Select Logo Download Mode —
ESC L G n CR LF |Select Logo Download Memory —
Location
ESC L G ©xFF CR LF |Stop Logo Download Process —
ESC L gn Print Logo —
Download—Fonts
ESC D F CR Enable Font Downloading —
ESC F I CR Display Tables Information —
ESC D I CR
ESC F X Disable Font Download Mode —
ESC F S m t k Ff CR |Display Font Download Current —
Settings
ESC F P m t k Ff CR|Set Font Download Parameters —
ESC F M m CR Select Load Operating Mode —
ESC F F f CR Select Font Row —
ESC F K kR CR Select Font Column —
ESC F L t CR Select File Type —
ESC F B CR Save Font File in Flash —
Bluetooth and Wifi Setup Commands
ESC P U n1 U n2 |Select Pass-Thru Command —
T to t1 t2 (CR) |Mode
Emulation
ESC E n Select Emulation v
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Set/Get/Do (SGD) Commands

Set/Get/Do (SGD) Commands

The following SGD commands were added for use with your Virtual Device app. For
more detailed information on SGD commands, see the Programming Guide for
ZPL II®, ZBl 2, Set/Get/Do, Mirror, and WML (formerly the ZPL Il Programming

Guide).

apl.enable

Description This command enables or disables a Virtual Device app.

- Note °
+ ZPL and CPCL may not function normally when a Virtual Device app is enabled.
* You must restart the printer after changing the value of apl.enable.

Type setvar

Commands Details
setvar This command instructs the printer to enable a virtual device.
Format: ! Ul setvar "apl.enable" "value"
Values:
"apl-ax" = enable Virtual Device-Ax
"none" = disable any Virtual Device app (ZPL and CPCL function normally)
—l Example 1 ¢ This example shows how to enable the Virtual Device-Ax app:
! Ul setvar "apl.enable" "apl-ax"
—p Example 2 « This example shows how to disable the Virtual Device-Ax app:
! Ul setvar "apl.enable" "none"
apl.version

Description This command returns the version of the currently running Virtual
Device app.

Type getvar

Commands Details

getvar Format: ! Ul getvar "apl.version"
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apl.framework_version

Description This command returns the level of support for Virtual Devices in the
printer operating system.

Type getvar

Commands Details

getvar Format: ! Ul getvar "apl.framework version"
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Supported Fonts

This section provides you with examples of the fonts available on the Zebra printers
with Virtual Device-Ax.

Contents
Supported FONts. . . ... . e 43
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Table 1 * Supported Fonts
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Table 1 » Supported Fonts (Continued)
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ZDownloader Utility

This section provides you with the instructions for downloading and installing the
ZDownloader Utility.

Contents
Downloading the ZDownloader Utility ... ........ ... ... ... . . . . .. 46
Installing the ZDownloader Utility. . .. ... .. .. . 47
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Downloading the ZDownloader Utility

Downloading the ZDownloader Utility

To download the ZDownloader Utility, perform the following from your
computer:

1.

2,

Open a web browser and navigate to http://www.zebra.com.

Click on the Support & Downloads header on the web page.

Select a printer.

When the printer page opens, locate and select the Software Utilities tab.

Scroll down to the ZDownloader Utility and select the Download link.

Note ¢ You will be prompted to create a user profile or login to
http://www.zebra.com with an existing profile to download the ZDownloader Utility.

Click on the Accept and Begin Download Now button.
The installation file download will begin.

P1079049-003

Virtual Device-Ax User Guide 08/28/2018


www.zebra.com
www.zebra.com

ZDownloader Utility | 47
Installing the ZDownloader Utility

Installing the ZDownloader Utility
To install the ZDownloader Utility, perform the following from your computer:
1. Run the installation file after the download is complete.

2. If you are prompted to allow the application to make changes to your computer,
click Yes.

The utility installs on your computer. When installation is complete, the Firmware
Downloader and ZBI Key Manager installation wizard appears.

Zebra Setup Utilities - InstallAware Wizard — *

Welcome to the InstallAware Wizard for Zebra
Setup Utilities

The Installtware Wizard will install Zebra Setup Utilities on yvour
computer.

N\

\o

WARMING: This program is protected by copyright law and
international treaties.

To continue, dlick Mext.

< pack Cocel

3. Click Next.
The End User License Agreement appears.
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4. Read the terms of the agreement.

% Zebra Setup Utilities - Installiware Wizard — >
License Agreement
Please carefully read the following license agreement. % ZEBRA
END USEE. LICENSE AGREEMENT ~
(UNRESTRICTED SOFTWARE)

IMPORTANT PLEASE READ CAREFULLY: This End User License Agreement ("EULA") is a legal agreement between
you (either an mdridual or a single entity) and Zebra International Heldings Corporation (" Zebra") for software.
owned by Zebra and its affiliated companies and its third party suppliers and licensers, that accompanies this EULA.
("Software"). BY USING THE SOFTWARE, YOU ACKNOWLEDGE ACCEPTANCE OF THE TERMS OF THIS EULA.
IF YOU DO NOT ACCEPT THESE TERMS, DO NOT USE THE SOFTWARE.

1 A ANT AT TTETAICT Talen cenmdn rrans Tend TThoe SChandoeonne #ha Follormmm e cimthdn secenidad #had srmes ammneler medts a1 o

[] T accept the terms of the license agreement

< Back Mext = Cancel

5. Click the checkbox to accept the terms.
6. Click Next.
The installation wizard displays information about the installation.
# Zebra Setup Utilities - InstallAware Wizard - *

Completing the InstallAware Wizard for Zebra
Setup Utilities

The Installdware Wizard is now ready to configure Zebra Setup
Utilities on this computer.

- Click Next to begin configuration

- Click Back to change settings

- Click Cancel to exit

< soc Cancl
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7. Click Next.
The installation wizard installs the application.

ZDownloader Utility
Installing the ZDownloader Utility

$. Zebra Setup Utilities - InstallAware Wizard — et

Installing Zebra Setup Utilities
The program features you selected are being configured.

L ZEBRA

A Plzase wait while the Installtware Wizard installs Zebra Setup Utilities.

I .‘%—-" This may take several minutes.

Status:

File: BAZR3I18Z.BA0, Directory: C:\Program Files (x86)\Zebra
Technologies\Zebra Setup Utilities\Driver\ZBRN\Common), Sze: 571

8. Click Finish to close the wizard.

$. Zebra Setup Utilities - InstallAware Wizard — *

Completing the Wizard for Zebra Setup Utilities

You have successfully completed the Wizard for Zebra Setup
Utilities.

O Run Zebra Setup Utilities now

O Read Readms

To dose this wizard, dick Finish.

Finish
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application installation
acquiring the app, 10
canceling a download in progress, 21
downloading the app to printers, 19
auto-detect printers, 12

C

commands and command parameters, 35
connectivity options, 7

D

disabling the Virtual Device
by apl.enable SGD command, 40
through the control panel
QLn320 and QLn220 printers, 27
QLn420 printers, 24
Supported ZTxxx and ZDxxx Printers with a
Display, 30
ways to enable/disable, 23

E

enabling the Virtual Device
by apl.enable SGD command, 40
through the control panel
QLn320 and QLn220 printers, 27
QLn420 printers, 24
Supported ZTxxx and ZDxxx Printers with a
Display, 30
ways to enable/disable, 23

IndeXx

F

features, 6
fonts, 42

IP Ethernet printers
auto-detect, 12
manually add, 13

L
liability, 2

manually add printers, 13
modifying printer communication settings
through ZDownloader, 17

parallel printers, 13
print servers, 7

S

serial interface

add printers, 13
Set/Get/Do (SGD) commands, 40
supported fonts, 42
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USB printers, 12
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\'} Z
version ZDownloader
level of support for Virtual Devices, 41 adding printers, 11
of Virtual Device, 40 canceling a download in progress, 21
Virtual Device version, 40 deleting printers, 18
downloading the Virtual Device app to printers,
W 19

downloading ZDownloader, 46
installing ZDownloader, 47
modifying printer settings, 17
zebra printer setup utility for android devices, 11

wired print server
auto detect, 12
for more information, 7
manually add, 13
wireless print server
auto detect, 12
for more information, 7
manually add, 13
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